News Packages

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend / Core
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version NuTyX 10.4
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: News Packages
Opened by Cédric - 02.12.2018
Last edited by tnut - 29.12.2018

FS#24 - New package for msmtp

Hello, I tried to create a new package for msmtp, unfortunately I can’t send any mail with msmtp. I get the following error:

msmtp: erreur d'utilisation du fichier de confiance X509 /etc/ssl/certs/ca-certificates.crt pour la session TLS : Erreur de lecture de fichier.
msmtp: le courriel n'a pas pu être envoyé (compte default dans /home/user/.msmtprc)

Here is the Pkgfile:

# Depends on: gnutls
description="A mini smtp client"
packager="Rocket"
url="https://marlam.de/msmtp/"
name=msmtp
version=1.8.0
release=2
source=("https://marlam.de/${name}/releases/${name}-${version}.tar.xz")

build() {
  cd $name-$version

  ./configure --prefix=/usr --sysconfdir=/etc --with-libgsasl \
  --with-tls=gnutls

  make
  make DESTDIR="$PKG" install
}

I had to choose between gnutls and openssl, I have no idea what is the best. From the documentation it was recommended to take gnutls, you can
choose to openssl if it’s better.

Closed by  tnut
29.12.2018 22:02
Reason for closing:  Recept added
Rémy W commented on 02.12.2018 12:50

Hello, gnutls seems to be a good choice. Thanks for your recipe

Cédric commented on 03.12.2018 15:12

I have tested and it works. The problem was not with the Pkgfile, but with the configuration file. I have added in .msmtprc

tls_trust_file /etc/ssl/ca-bundle.crt

And the problem is solved. Thank you!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing